Firefox Version 3.6 and the Surfulater Firefox Extension may not work

The current Surfulater Firefox Extension does not work if you do a clean installation of Firefox Version 3.6. If you upgrade to Firefox V3.6 from an earlier version of Firefox the Extension will continue to work correctly.

The folks at Mozilla have removed some of the code used by extensions prior to Firefox V3.6, which is preventing our extension from working. Specifically none of the Surfulater menu items appear on the Firefox right click context menu, even though the Extension appears to be installed ok. That’s the bad news.

The goods news is I have updated the Surfulater Firefox Extension to bring it up to date with the latest Firefox Extension specification. I have also taken this opportunity to update and improve the Extension code. A few Surfulater users have tested the new extension as have I and all is well once more.

The updated extension will be part of the next Surfulater release, Version 3.30, due out early next week. There are some great new features and enhancements in V3.30 which I’ll talk about in the next blog post.

I’m heading back to finish updating the Surfulater Help for the new release, then on to the release packaging and final testing.  I’ll see you all on the other side.

This entry was posted in General, Surfulater, Surfulater - Tech Info and tagged , . Bookmark the permalink.

Leave a Reply

Your email address will not be published. Required fields are marked *

*

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>